Como dice la gente que sabe de esto, el imprimir piezas 3D con calidad solo es cuestión de “calibrar, calibrar y calibrar”.

En este artículo vamos a ver el proceso de calibración del extrusor. Se trata de conseguir que cuando queremos extruir una cantidad determinada de plástico ésta sea lo más exacta posible. El proceso es extremadamente sencillo, y consiste en hacer una extrusión de una cantidad concreta de filamento, medir la extrusión realizada y en función de la relación entre ambas determinar unas constantes más correctas que las estándar para nuestra impresora.

Aunque esta calibración se está haciendo en un impresora 3d Prusa i3, el procedimiento es totalmente válido para otros tipos de impresoras.

Para hacerlo sólo necesitamos un calibre (si no se tiene calibre se puede usar una regla pero tendremos menor precisión) y algo que nos permita marcar el filamento de plástico. Nosotros usaremos cinta aislante enrollada en el filamento.

Veamos el sencillo proceso:

  • Marcamos el filamento a unos 7cm de donde entra en el extrusor (no es importante esta medida, sólo hay que dejar suficiente para hacer un par de medidas)
  • Medimos la distancia entre la marca y el extrusor con el calibre y lo ponemos a cero. Es muy importante que la medida se pueda hacer lo más precisa posible, porque de lo contrario no valdrá para nada.
  • Hacemos una extrusión a una velocidad baja (para evitar que aparezcan otros problemas como pérdida de pasos etc) de un cierto tamaño.  Nostros haremos varias de 30mm a 50mm/min
  • Hemos obtenido estos valores
velocidad medida
50 30,87
50 30,67
100 29,37
300 27,87

Vemos que para velocidades altas se producen resultados peores, esto es debido a que se pueden perder pasos. Por eso mejor usar de momento velocidades bajas, ya habrá tiempo de subirlas.

A partir de las distintas medidas podemos tomar 30.77cm  como valor medio. A partir de éste calcularemos las constantes que aparecen en el software que controla nuestra impresora 3D.

Para ello abrimos con el entorno de arduino el código del software que usamos (normalmente Sprinter o Marlin)

Seleccionamos el proyecto Sprinter y  en el fichero configuración configuration.h buscamos

#define _AXIS_STEP_PER_UNIT {80, 80, 3878.8, 777.6}
(En Marlin buscamos #define DEFAULT_AXIS_STEPS_PER_UNIT {78.7402,78.7402,200.0*8/3,760*1.1} )

Los 3 primeros valores se corresponden a los pasos de motor que deben de darse en cada dirección para moverse una cierta distancia (X, Y y Z),  siendo el cuarto el que nos indica los pasos para extruir una cierta cantidad de filamento. Este último será el que tenemos que modificar.

 

En nuestro caso usábamos el valor 777.6, hacemos una regla de 3 para calcular el nuevo valor.

Si 30.77mm es lo obtuvimos usando el factor 777.6 obtendrermos un valor de 30 con 30*777.6/30.77 = 758.14

Modificamos el valor en el fichero y volvemos a cargar el software en nuestra placa.

Volvemos  a hacer una medida

Y vemos que hemos obtenido un valor más preciso. Iterando este proceso podemos llegar a conseguir mayor precisión aún.

Por cierto, ¡¡¡hay que acordarse de quitar la cinta, si no lo hacemos podemos atascar nuestro extrusor!!!

Calibrando el extrusor de una impresora 3d prusa I3
Etiquetado en:            

28 thoughts on “Calibrando el extrusor de una impresora 3d prusa I3

  • 14 marzo, 2015 a las 20:02
    Enlace permanente

    Hola a todos!

    Quería preguntar si es normal que cuando estoy imprimiendo una pieza, el tornillo de alimentación de ABS del extrusor gire pero no coja plástico.

    No entiendo bien que es lo que sucede!

    Gracias por la atención.

    Un saludico desde mañolandia

    Responder
    • 15 marzo, 2015 a las 0:37
      Enlace permanente

      Hola Dani, pueden ser varias cosas:
      * Tu fusor está obstruido, solución: lìmpialo
      * Tu hobbed bolt no tiene suficientes dientes o está sucio: límpialo

      El saber la solución correcta pasa por desmontar el extrusor y comprobar con el fusor caliente que al empujar sale plástico
      Ya me cuentas si te sirve 😉

      Responder
  • 17 mayo, 2015 a las 17:51
    Enlace permanente

    Hola a todos!!
    El extrusor va perfecto, he limpiado todo y derrite bien el plástico.

    Mi problema es que cuando cargo una pieza para imprimir, el pronterface fija la temperatura del extrusor a 200 ºC, y no se que hacer.

    He cambiado los parametros de temperatura en el slicer, a 230ºC, pero aún así, cuando le doy a printer el sigue fijando a 200ºC la temperatura del extrusor.

    Gracias por la ayuda.
    Un saludo

    Responder
  • 22 julio, 2015 a las 4:08
    Enlace permanente

    Tengo una impresora (3d Prusa i3) cuando pongo a imprimir solo me hace el 6% y se detiene no se que hacer gracias.

    Responder
    • 7 octubre, 2015 a las 11:16
      Enlace permanente

      Hola, yo revisaría un par de cosas:
      * Cambia el cable USB por otro más corto y mejor apantallado
      * Mira a ver si la ventilación de tu electrónica es correcta y si la fuente puede con todo.

      Suerte

      Responder
    • 6 septiembre, 2016 a las 21:51
      Enlace permanente

      Es un problema de interferencias, cubre los cables con papel aluminio y solucionado

      Responder
  • 9 noviembre, 2015 a las 19:03
    Enlace permanente

    cuando imprimo una pieza el extrusor cambia de sentido en mitad del proceso y sigue imprimiendo la misma pieza y queda una parte de la pieza desplazada con lo cual queda todo mal, todo ello con una Prusa i3 Hefestos

    Responder
    • 10 noviembre, 2015 a las 11:56
      Enlace permanente

      Hola Adrian, se me ocurre dos posibles problemas:
      * El eje z no está calibrado y se desplaza menos de lo que debe y el extrusor roza y no se mueve lo suficiente. Pudieras tener un problema de calentamiento de la electrónica
      * Quizas los ejes x o y pierden pasos y el extrusor no se desplaza lo suficiente.

      Vigila que la electrónica no se caliente y prueba a recalibrar el eje z.
      No deje de contarnos si se soluciona.
      Saludos

      Responder
  • 21 noviembre, 2015 a las 4:11
    Enlace permanente

    Buernas tardes, Tengo el mismo problema que adrian, la pieza sale desplazada, tengo una wanhao i3, Alguna idea. Saludos desde México.

    Responder
    • 23 noviembre, 2015 a las 11:59
      Enlace permanente

      Hola, te comento lo mismo que a él: o fallo de calibración en el eje Z o falta de potencia de los motores (por exceso de temperatura o porque no están bien calibrados)
      Saludos

      Responder
  • 20 diciembre, 2015 a las 23:58
    Enlace permanente

    hola, yo tengo un extrusor mk9 y cuando hago la calibracion del extrusor va bien sale perfecto el filameto pero a la hora de imprimir el cubo de calibracion sale muy poco por lo cual nunca eh podido hacer un cubo ni algo que se le paresca ya que en la primera capa no tira nada pues despues se va pegando el filamento a la boquilla, sabes a que se debe.
    saludos

    Responder
    • 21 diciembre, 2015 a las 13:30
      Enlace permanente

      Hola Martin, Revisa todo lo que he comentado antes. ¿quizás no tienes bien el perfil de impresión y al imprimir falta plástico? Prueba a aumentar el flujo de plástico por encima del 100%

      Saludos y suerte

      Responder
  • 22 marzo, 2016 a las 10:33
    Enlace permanente

    Hola, he montado una prusa i3 y al imprimir, el motor del extrusor no se mueve por lo que el filamento no sale. No es problema de la temperatura porque si lo giro yo manualmente el filamento sale. Qque puede fallar? Saludos

    Responder
  • 14 abril, 2016 a las 0:05
    Enlace permanente

    Hola, estoy por armar una prusa i3 y me interesaria saber el tiempo que tarda en hacer un cubo de 1cm x 1cm x 1cm (o similar) en la velocidad “100” que se muestra en la lista del post. Gracias!

    Responder
  • 26 abril, 2016 a las 2:25
    Enlace permanente

    Hola soy nuevo en este campo tan emocionante, y tengo un problema cuando imprimo una pieza me sale un mallado en la parte donde apolla la pieza, imprimo con cura, me podrías decir porqué pasa esto?
    Gracias de antemano.

    Responder
  • 26 abril, 2016 a las 2:38
    Enlace permanente

    Hola, parece ser que mi pregunta no se subió por el error de mi correo, preguntaba porqué me sale un mallado donde apoya la pieza al imprimir con cura, gracias

    Responder
    • 17 mayo, 2016 a las 16:27
      Enlace permanente

      Hola Edu, supongo que la pieza tiene algún voladizo (alguna zona de la pieza no toca la base) y tienes activada la opción de soportes (support type!=none)
      Saludos

      Responder
  • 7 mayo, 2016 a las 2:13
    Enlace permanente

    ayuda, deseperado, tengo mi sunhokey prusa i3, ya armada como esta en los videos puesta la electronica y conectores con su guia, no e podido imprimir ya que si subo un archivo en la micro sd y preparo para imprimir, el extructor empiesa a calentar llega a los 190 grados y empiesa a bajar y se queda en 26 grados y ahi se queda, ya no se que hacer, si alguien e puede guiar, gracias

    Responder
    • 17 mayo, 2016 a las 16:28
      Enlace permanente

      Hola, Debes dejar la temperatura en modo automático (dejando 0 en el valor de la temperatura del filamento)
      Saludos

      Responder
  • 16 junio, 2016 a las 5:57
    Enlace permanente

    hola mi problema es que anda todo bien pero cuando activo la retraccion, el motor como que se satura y hace un ruido tipo pitido… he cambiado todos los parametros para la retraccion pero no pude hacerlo andar…. el problema es que ya cambie todos los parametros en el repetier en el cura en el slicer y en arduino y ya no se cuales son los valores adecuados… si alguien pudiera darme una mano se lo agradeceria , saludos

    Responder
    • 20 junio, 2016 a las 12:55
      Enlace permanente

      Hola Matias, supongo que el problema es que al motor no le llega suficiente corriente. La retracción hacer moverse al motor muy rápidamente y podría necesitar más.
      Ajusta el driver Pololu (A4888 o compatible) para que entregue más potencia.
      Suerte

      Responder
  • 17 julio, 2016 a las 22:44
    Enlace permanente

    De maravilla, quedo una pinturita, aunque lo hice con regla y una microfibra en vez de cinta y calibre, quedo finito finito el trabajo, justo ayer instale el cura 2.1.2 y me destrozo el marlin que tenia puesto! jajajaja ahora tengo que calibrar todo de nuevo.

    Responder

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *